The Pixie App

Pixie Works on iOS 7 and later and Android 4.4.2 and later

Supported Apple iOS Devices Using iOS 7 or 8:
iPhone 5, iPhone 5C, iPhone 5S, iPhone 6, iPhone 6+

Supported Android Devices Using 4.4.2 or Higher:
Samsung Galaxy S5, HTC One M8, Nexus 5

Pixie will be expanding the numbers of models supported, If your model in not on that list please send us your model and we will let you know when you can expect it to be supported.